zzak, make distclean is the first thing I've ran. Read the gist again :),
even more after that I've ran git clean.

On Thu, Dec 19, 2013 at 6:52 PM, zzak (Zachary Scott) <e / zzak.io> wrote:

>
> Issue #9264 has been updated by zzak (Zachary Scott).
>
> Category set to build
> Status changed from Open to Feedback
>
> Can you try 'make distclean' and then try again?
> ----------------------------------------
> Bug #9264: Compiling error: encdb.bundle Undefined symbols for
> architecture x86_64
> https://bugs.ruby-lang.org/issues/9264#change-43766
>
> Author: spastorino (Santiago Pastorino)
> Status: Feedback
> Priority: Normal
> Assignee:
> Category: build
> Target version: current: 2.1.0
> ruby -v: 2.1
> Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN
>
>
> Using today's trunk, I'm getting the following error on compiling
>
> compiling ./enc/encdb.c
> linking encoding encdb.bundle
> Undefined symbols for architecture x86_64:
>   "_rb_enc_set_base", referenced from:
>       _Init_encdb in encdb.o
>   "_rb_enc_set_dummy", referenced from:
>       _Init_encdb in encdb.o
>   "_rb_encdb_alias", referenced from:
>       _Init_encdb in encdb.o
>   "_rb_encdb_declare", referenced from:
>       _Init_encdb in encdb.o
>   "_rb_encdb_dummy", referenced from:
>       _Init_encdb in encdb.o
>   "_rb_encdb_replicate", referenced from:
>       _Init_encdb in encdb.o
>   "_rb_encdb_set_unicode", referenced from:
>       _Init_encdb in encdb.o
> ld: symbol(s) not found for architecture x86_64
>
> Here is the full trace ...
>
> https://gist.github.com/spastorino/1ad2858fce42d0e0a2e2
>
> Thanks in advance.
>
>
> --
> http://bugs.ruby-lang.org/
>