Hi,

In <52AD2EE4.7050009 / atdot.net>
  "[ruby-core:59119] Naming issue about ObjectSpace.trace_object_allocation." on Sun, 15 Dec 2013 13:24:04 +0900,
  SASADA Koichi <ko1 / atdot.net> wrote:

> * The name of sourcefile and sorceline are based on "rb_sourcefile" and
> "rb_sourceline".

In my opinion...

If ObjectSpace.allocation_sourcefile and _sourceline are
CRuby implementation specific APIs, it is better that we use
"sourcefile" and "sourceline". Because they represent
corresponding feature.

If they are not Ruby implementation specific APIs, we
doesn't need to follow naming rules used in CRuby
implementation. It will be better that we use naming
convention in Ruby script world instead of one in Ruby
implementation world.

> * The name of "allocation" is from "trace_object_allocations" (I want to
> use same word `allocation').

How about introducing ObjectSpace::Allocation namespace?

  * ObjectSpace::Allocation.sourcefile
  * ObjectSpace::Allocation.sourceline
  * ObjectSpace::Allocation.class_path
  * ObjectSpace::Allocation.method_id
  * ObjectSpace::Allocation.generation

It is not strange that noun (allocation) is used for module
name.

> # bike shed party

I should not comment about this?

Thanks,
--
kou