Issue #9142 has been reported by mlarocque (Michael Larocque).

----------------------------------------
Bug #9142: Ruby 2.0.0 crash in Rake/mysql2
https://bugs.ruby-lang.org/issues/9142

Author: mlarocque (Michael Larocque)
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 
ruby -v: ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-darwin12.3.0]
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN


Hi folks,

I've spent the past couple of days trying to decipher a ruby crash. I've googled, etc and followed the 'How to Report bugs in Ruby' page. I'm looking for any advice to try to track this down.

Here's the relevant data:

* OS X 10.8.3 on a Mac mini
* Ruby: ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-darwin12.3.0]
* Rake Version: 10.1.0
* I'm using rvm (rvm 1.24.3)
* I'm deploying using capistrano 3.0.1
* I'm developing a new application using Rails 4.0.1
* My last successful deploy was a couple of weeks ago
* A few days ago, I added a model, controller, some views, etc to the application (nothing special)
* Deploying the changes failed with a ruby crash (details attached)
* Upon further investigation, I can run rake (e.g. rake -T) in my previous successful deploy directory
* Attempting to run rake in any subsequent deployed directory on the server results in a ruby crash

It seems to be happening in the mysql2 gem. I've uninstalled and reinstalled the gem with no change in the outcome.

I've looked at the crash report and the various traces and I'm stuck. I'm looking for any suggestions to help me track down this issue.
Please let me know if there's anything else that I can provide.

Thanks,
Mike



-- 
http://bugs.ruby-lang.org/