Issue #9117 has been updated by nagachika (Tomoyuki Chikanaga).


As same as #8879, it maybe reproducible only when configure'd with --with-static-linked-ext. But I cannot reproduce too.

$ configure --prefix=${HOME}/ruby-2.0.0-static --with-static-linked-ext
$ make
$ make install
$ ${HOME}/ruby-2.0.0-static/bin/ruby -ropenssl -e 'puts Digest::SHA512.new'

Is transferring binary to other machine required to reproduce?
----------------------------------------
Bug #9117: 43656 breakes openssl in stalic-ext ruby
https://bugs.ruby-lang.org/issues/9117#change-43046

Author: mpapis (Michal Papis)
Status: Feedback
Priority: Normal
Assignee: 
Category: 
Target version: 
ruby -v: ruby 2.0.0p247 (2013-06-27 revision 41674) [universal.x86_64-darwin13]
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN


=begin

while fixing #8879 a new bug was introduced in ((<r43656|URL:https://bugs.ruby-lang.org/projects/ruby-200/repository/revisions/43656>)).

without the patch ruby-2.0.0-p247 - (({ruby -ropenssl -e 'puts Digest::SHA512.new'})):

 cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e

with the patch ruby-2.0.0-p247 - (({ruby -ropenssl -e 'puts Digest::SHA512.new'})):

 /Users/mpapis/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require': undefined class/module Digest::Base (ArgumentError)
 	from /Users/mpapis/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 	from /Users/mpapis/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/digest.rb:12:in `const_missing'
 	from -e:1:in `<main>'

=end



-- 
http://bugs.ruby-lang.org/