On 2002-11-17 02:25:10 +0900, Yukihiro Matsumoto wrote:
> |We have a method just like that in JRuby, which we use a lot internally.
> |But we've named it "group_by", inspired by SQL.
> 
> I prefer "group_by" to "partition_by".  Could it be just "group",
> since we have "select" not "select_by"?

"group" or "group_by" is perhaps a better name, because it is shorter. I
named the method "partition_by" because it is somehow related to
"partition". The returned hash's values are a more general partition.

-- 
If you pick up a starving dog and make him prosperous, he will not bite you; 
that is the principal difference between a dog and a man.
  -- Mark Twain