At Sun, 17 Nov 2002 02:25:10 +0900,
matz wrote:
> |We have a method just like that in JRuby, which we use a lot internally.
> |But we've named it "group_by", inspired by SQL.
> 
> I prefer "group_by" to "partition_by".  Could it be just "group",
> since we have "select" not "select_by"?

group is also a very common noun and I'm afraid it might clash with
the attribute named "group" in some Enumerable classes.

-- 
                     /
                    /__  __            Akinori.org / MUSHA.org
                   / )  )  ) )  /     FreeBSD.org / Ruby-lang.org
Akinori MUSHA aka / (_ /  ( (__(  @ iDaemons.org / and.or.jp

"When I leave I don't know what I'm hoping to find
              When I leave I don't know what I'm leaving behind.."