On Oct 14, 2013 5:00 PM, "headius (Charles Nutter)" <headius / headius.com>
wrote:
>
> Ok, let's just focus on #1 for now...
>
> It seems like everyone agrees that "string".freeze is a better choice
than adding incompatible syntax now. That was the original proposal in this
issue.
>
> Should we remove "string"f on master and replace it with charliesome's
patch for "string".freeze? Or do we want to bikeshed a shorter name?
>
> It occurred to me the there's already "string".b which returns a binary
string. Should we consider "string".f which is similar to "string"f syntax
but is just a normal method?
>
> I think we're in agreement that we want the method format rather than the
"f" suffix, so it's just a matter of deciding if we want a different method
name for the new compiler-aware method.

Yes. I feel like regexen have suffixes because of decades of perl
precedence, but they (suffixes) don't belong anywhere else.

For a method, I feel like #freeze is the better name, my only question is:
is anyone monkeypatching it (and therefore will be bitten by this
optimisation)? I doubt it, but we should still ask. The same question would
have to be asked of the new method; I think there's more chance of #f being
used in the wild than an overridden #freeze

Also in the favour of #freeze, it gives existing code a boost without any
modification.

Sent from my phone, so excuse the typos.