Issue #8769 has been updated by nobu (Nobuyoshi Nakada).

Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN to 1.9.3: DONTNEED, 2.0.0: REQUIRED


----------------------------------------
Bug #8769: [PATCH] process.c (rb_fork_internal): remove cloexec setting
https://bugs.ruby-lang.org/issues/8769#change-41919

Author: normalperson (Eric Wong)
Status: Closed
Priority: Low
Assignee: nobu (Nobuyoshi Nakada)
Category: core
Target version: current: 2.1.0
ruby -v: ruby 2.1.0dev (2013-08-10 trunk 42491) [x86_64-linux]
Backport: 1.9.3: DONTNEED, 2.0.0: REQUIRED


The close-on-exec flag is already set via:
  pipe_nocrash -> rb_pipe -> rb_cloexec_pipe
Calling fcntl here is redundant.


-- 
http://bugs.ruby-lang.org/