On Aug 10, 2013, at 7:46 PM, trans (Thomas Sawyer) wrote:

> Based on this line of reasoning I formally request the Hash#| be an =
alias of Hash#merge.

Issue #7739 is similar, but requests that Hash#| be added an alias for =
ActiveSupport's Hash#reverse_merge.

I think that the functionality of ACtiveSupport's Hash#reverse_merge is =
more inline with your Array#| analogy than Hash#merge would be.

Dave