Issue #8601 has been updated by luislavena (Luis Lavena).


usa (Usaku NAKAMURA) wrote:
> Win32API.rb should be removed at 2.1.0.

Hello usa,

This doesn't go against what nobu and arton said?

I can modify both RubyGems and SecureRandom to use Fiddle (for newer versions) but not sure about the enterprise environments that have no access to gems.

Thank you.
----------------------------------------
Feature #8601: Win32API.rb long life plan
https://bugs.ruby-lang.org/issues/8601#change-40698

Author: arton (Akio Tajima)
Status: Assigned
Priority: Normal
Assignee: usa (Usaku NAKAMURA)
Category: lib
Target version: current: 2.1.0


Win32API.rb sits on ext/dl/win32/lib in the source tree.
But DL is deprecated on Ruby 2.0.1, so I'd like to move it from ext/dl/win32/lib to ext/win32/lib because the library is fundamental for Win32 platform.
Also it's required to fit Fiddler.

Attachment is the patched version of Win32API.rb for both DL and Fiddle based on mirich (http://d.hatena.ne.jp/mirichi/20130629/p1).



-- 
http://bugs.ruby-lang.org/