Issue #8612 has been updated by zzak (Zachary Scott).

Category set to lib
Status changed from Open to Assigned
Assignee set to seki (Masatoshi Seki)


----------------------------------------
Bug #8612: nil in ERB::Util.url_encode
https://bugs.ruby-lang.org/issues/8612#change-40405

Author: fotos (Fotos Georgiadis)
Status: Assigned
Priority: Normal
Assignee: seki (Masatoshi Seki)
Category: lib
Target version: 
ruby -v: 1.9.3p448, 2.0.0p255
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN


=begin
We hit a bug while using Rails and trying to URL encode an ActiveSupport::SafeBuffer. I have managed to reproduce it using a small test case for Ruby 1.9.3 and Ruby 2.0.0 (both attached) that shows a minimum set of requirements to trigger the bug. The issue seems to be fixed in trunk (2.1) but I couldn't find the relevant commit(s).

To reproduce:
  require 'erb'

  class MyString < String
    def to_s
      self
    end

    def gsub(*args, &block)
      to_str.gsub(*args, &block)
    end
  end

  string = "\xCE\x94\xCE\xBF\xCE\xBA\xCE\xB9\xCE\xBC\xCE\xAE".force_encoding("UTF-8")

  ERB::Util.u(MyString.new(string))

Expected outcome:

The URL encoding should work and it should encode the characters properly (according to the spec).

Actual outcome:

  NoMethodError: undefined method `unpack' for nil:NilClass
    /Users/fotos/Playground/OpenSource/ruby/lib/erb.rb:952:in `block in url_encode'
    /Users/fotos/Playground/OpenSource/ruby/test/erb/test_erb.rb:71:in `gsub'
    /Users/fotos/Playground/OpenSource/ruby/test/erb/test_erb.rb:71:in `gsub'
    /Users/fotos/Playground/OpenSource/ruby/lib/erb.rb:951:in `url_encode'
    /Users/fotos/Playground/OpenSource/ruby/test/erb/test_erb.rb:491:in `test_url_encode_string_subclass'

Using

Workaround:

Yielding the match and using it instead of $& (last match) seems to work properly as demonstrated in the patch.

Thanks

PS. Some credits go out to Aggelos Orfanakos (@agorf) for triggering the bug! :-)
=end


-- 
http://bugs.ruby-lang.org/