Issue #8584 has been reported by shugo (Shugo Maeda).

----------------------------------------
Bug #8584: Remove curses
https://bugs.ruby-lang.org/issues/8584

Author: shugo (Shugo Maeda)
Status: Assigned
Priority: Normal
Assignee: matz (Yukihiro Matsumoto)
Category: ext
Target version: current: 2.1.0
ruby -v: 2.1.0dev
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN


I'd like to remove curses from the Ruby standard library.

I believe the standard library should get as small as possible, and I can't find any reason to have curses except for a compatibility reason.  And Ruby has RubyGems now, so it's enough to have curses.gem for compatibility.

I've created a repository for curses.gem.

  https://github.com/shugo/curses

I'm not a user of curses now, so it would be great if someone can take over it.

Can I remove curses from Ruby 2.1?


-- 
http://bugs.ruby-lang.org/