--e89a8ffbace3309e2804df608d92
Content-Type: text/plain; charset=ISO-8859-1

+1
On Jun 18, 2013 1:25 AM, "naruse (Yui NARUSE)" <naruse / airemix.jp> wrote:

>
> Issue #8539 has been reported by naruse (Yui NARUSE).
>
> ----------------------------------------
> Feature #8539: Unbundle ext/tk
> https://bugs.ruby-lang.org/issues/8539
>
> Author: naruse (Yui NARUSE)
> Status: Open
> Priority: Normal
> Assignee:
> Category: ext
> Target version: current: 2.1.0
>
>
> How about unbundling ext/tk from Ruby repository?
>
> ext/tk is a bundled extension library for GUI programming with tk.
> It is introduced in 1999 and long maintained with CRuby itself.
>
> But nowadays its maintenance is not so active.
> Moreover ext/tk is not the de facto standard over Ruby GUI though it is
> bundled for 14 years.
> (maybe because tk is not de facto of GUI toolkit)
> GUI libraries for Ruby should compete in the wilds.
>
> So I propose unbundling ext/tk.
> It should be another repository for example on github and people should
> install it as gem.
>
> How do you think?
>
>
> --
> http://bugs.ruby-lang.org/
>
>

--e89a8ffbace3309e2804df608d92
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

<p>+1</p>
<div class="gmail_quote">On Jun 18, 2013 1:25 AM, &quot;naruse (Yui NARUSE)&quot; &lt;naruse / airemix.jp&gt;rote:<br type="attribution"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
Issue #8539 has been reported by naruse (Yui NARUSE).<br>
<br>
----------------------------------------<br>
Feature #8539: Unbundle ext/tk<br>
<a href="https://bugs.ruby-lang.org/issues/8539" target="_blank">https://bugs.ruby-lang.org/issues/8539</a><br>
<br>
Author: naruse (Yui NARUSE)<br>
Status: Open<br>
Priority: Normal<br>
Assignee:<br>
Category: ext<br>
Target version: current: 2.1.0<br>
<br>
<br>
How about unbundling ext/tk from Ruby repository?<br>
<br>
ext/tk is a bundled extension library for GUI programming with tk.<br>
It is introduced in 1999 and long maintained with CRuby itself.<br>
<br>
But nowadays its maintenance is not so active.<br>
Moreover ext/tk is not the de facto standard over Ruby GUI though it is bundled for 14 years.<br>
(maybe because tk is not de facto of GUI toolkit)<br>
GUI libraries for Ruby should compete in the wilds.<br>
<br>
So I propose unbundling ext/tk.<br>
It should be another repository for example on github and people should install it as gem.<br>
<br>
How do you think?<br>
<br>
<br>
--<br>
<a href="http://bugs.ruby-lang.org/" target="_blank">http://bugs.ruby-lang.org/</a><br>
<br>
</blockquote></div>

--e89a8ffbace3309e2804df608d92--