Hi,

I use $SAFE in ActiveScriptRuby (IActiveScript interface for ruby) for
implementing IObjectSafety interface (Ixxx is defined by Component
Object Model specification but I think it's not your concern so I don't
describe it).
My living code is "rb_safe_level() >= 3" , so it's ok to remove level 4
but I'm not pleased to remove it completely.

Regards

-- 
arton <artonx / yahoo.co.jp>