Issue #5458 has been updated by luislavena (Luis Lavena).


tenderlovemaking (Aaron Patterson) wrote:
> DL is deprecated in trunk.  To maintain backwards compatibility, I've moved some parts of DL to Fiddle.  We should be able to remove `ext/dl` after 2.0 release.

What parts of DL remain to be migrated to Fiddle?

With DL being deprecated, Win32API component and win32/registry will need to be changed or removed entirely.

----------------------------------------
Feature #5458: DL should be removed 
https://bugs.ruby-lang.org/issues/5458#change-39434

Author: kosaki (Motohiro KOSAKI)
Status: Assigned
Priority: Normal
Assignee: mame (Yusuke Endoh)
Category: ext
Target version: current: 2.1.0


DL and fiddle are redundant. Moreover DL has no maintainer and its code is problematic.


-- 
http://bugs.ruby-lang.org/