(13/05/17 17:01), aleph1 (Elias Levy) wrote:
> map may be the best choice, as its already used in enumerables and this is a natural equivalent for single objects.  That said, it may lead to unnoticed bugs if someone thinks they are applying a map operation on an enumerable but for some reason they do so against some other object.  So maybe one of the other names is better to ensure such cases fail.

If it were Kernel#map, which would you expect by `{foo: 42}.map {...}` ?