On Wednesday, 8 May 2013 at 4:35 AM, Hanmac (Hans Mackowiak) wrote:
> i am against that, what about methods that are defined in Kernel, but you want when you are inside an BasicObject?
> you need something like:
> Kernel::Array([])
> or
> Kernel.Array([])
> what does make more sense for you?

I actually prefer the '::Kernel.Array' example here (although I can see both sides of the argument), just because it makes it perfectly obvious that 'Array' is actually a method call and not something else.

On Wednesday, 8 May 2013 at 6:03 AM, Eregon (Benoit Daloze) wrote:

> This is a weird case due to the upper case first letter, what do you think about:
> ::Kernel::puts "Hello"
> versus
> ::Kernel.puts "Hello"

I definitely think '::Kernel.puts' is better here.