Issue #8213 has been updated by Eregon (Benoit Daloze).


zzak (Zachary Scott) wrote:
> @eregon Hi! Yes, nobu pointed out another way here: https://twitter.com/n0kada/status/328342207511801856
> 
> Want to write a patch?

Still a bit hacky but sure I will do that :)
----------------------------------------
Bug #8213: No documentation for `ri YAML`
https://bugs.ruby-lang.org/issues/8213#change-39002

Author: injekt (Lee Jarvis)
Status: Closed
Priority: Normal
Assignee: zzak (Zachary Scott)
Category: doc
Target version: current: 2.1.0
ruby -v: 2.0.0-p0
Backport: 


I believe the RI output for YAML needs to be fixed to display more detailed information on usage. Currently, it displays nothing. I'm happy to start some documentation on the YAML const in lib/yaml.rb with any pointers in the right direction. View below for more information:

$ ri YAML # Ruby 1.9

= YAML

(from ruby core)
------------------------------------------------------------------------------
The YAML module allows you to use one of the two YAML engines that ship with
ruby.  By default Psych is used but the old and unmaintained Syck may be
chosen.

See Psych or Syck for usage and documentation.

To set the YAML engine to syck:

  YAML::ENGINE.yamler = 'syck'

To set the YAML engine back to psych:

  YAML::ENGINE.yamler = 'psych'
------------------------------------------------------------------------------
= Constants:

ENGINE:
  Allows changing the current YAML engine.  See YAML for details.

$ ri YAML # Ruby 2.0.0 (and trunk)
= YAML

------------------------------------------------------------------------------
Also found in:
  ruby core


-- 
http://bugs.ruby-lang.org/