> I'm seriously asking because I'm known for assuming whining where folks
are merely enumerating issues they've run into.

Throughout the development of Ruby 2.0, it was stated that it would be
backwards-compatible with 1.9.