Issue #8134 has been updated by naruse (Yui NARUSE).


It seems because your clang is too old; use newer clang or gcc-4.2.
Or report rvm to use gcc-4.2 prior clang/llvm-gcc.
----------------------------------------
Bug #8134: Compilation failure for 2.0.0 on 10.6.8
https://bugs.ruby-lang.org/issues/8134#change-37803

Author: vschiavoni (Valerio Schiavoni)
Status: Third Party's Issue
Priority: Normal
Assignee: 
Category: 
Target version: 
ruby -v: Apple clang version 1.7 (tags/Apple/clang-77) (based on LLVM 2.9svn)


Trying to install 2.0.0 with rvm on Mac OSX 10.6.8, the installation fails.  



-- 
http://bugs.ruby-lang.org/