Issue #8000 has been updated by jonforums (Jon Forums).


> First of all, current Ruby/Tk cannot support Tcl/Tk8.6. Please see [ruby-talk:395829].
> But, I don't know whether this trouble belongs to the "tailcall" problem or not.

Nagai-san: thanks for the info. FYI, while it's not really relevant to Ed's Arch issue, I'm running Tcl/Tk8.6 on Win7 32bit on `ruby 1.9.3p393` and `ruby 2.0.0p19` built with mingw-w64 4.7.2 and I've not yet seen any problems with test scripts like http://pastie.org/6420781
----------------------------------------
Bug #8000: "require 'tk'" segfaults on 64-bit linux with Tk 8.6
https://bugs.ruby-lang.org/issues/8000#change-37395

Author: edmccard (Ed McCardell)
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 
ruby -v: ruby 1.9.3p392 (2013-02-22 revision 39386) [x86_64-linux]


Using ruby 1.9.3p392 and Tk 8.6.0 on 64-bit Arch Linux, attempting to "require 'tk'" causes a segfault.

To reproduce:
    ruby -e "require 'tk'"

The crash log is in the attached file.

Notes:
- I've heard from a Gentoo user who is having the same problem.
- On 32-bit Arch Linux, there is no problem.


-- 
http://bugs.ruby-lang.org/