Issue #8019 has been updated by nobu (Nobuyoshi Nakada).

Category set to lib
Status changed from Open to Assigned
Assignee set to drbrain (Eric Hodel)
Target version set to current: 2.1.0

=begin
I'm uncertain this is related to this issue, SSLErrors are shown with
ruby -d option.

  Exception `OpenSSL::SSL::SSLError' at /opt/local/lib/ruby/2.1.0/net/http.rb:917 - SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol
  Exception `OpenSSL::SSL::SSLError' at /opt/local/lib/ruby/2.1.0/net/http.rb:925 - SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol
  Exception `Gem::RemoteFetcher::FetchError' at /opt/local/lib/ruby/2.1.0/rubygems/remote_fetcher.rb:407 - SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol (http://gems.github.com/latest_specs.4.8.gz)
  Exception `Gem::RemoteFetcher::FetchError' at /opt/local/lib/ruby/2.1.0/rubygems/remote_fetcher.rb:282 - SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol (http://gems.github.com/latest_specs.4.8.gz)
=end

----------------------------------------
Bug #8019: Ruby 2.0.0p0 does not list remote gems anymore
https://bugs.ruby-lang.org/issues/8019#change-37305

Author: rubycoder (Ike Miller)
Status: Assigned
Priority: High
Assignee: drbrain (Eric Hodel)
Category: lib
Target version: current: 2.1.0
ruby -v: 2.0.0p0 (2013-02-24) [i386-mingw32]


gem list --remote --source http://gems.github.com

-just prints "*** REMOTE GEMS ***" then sits in an endless loop; same for other gem-repositories.
-tested it with 1.9.2 from same PCs: worked fine, so it is really a 2.0.0 problem
-tested it with 32bit and 64bit installers on different PCs (XP & Win7/64): always same result, reproducable error



-- 
http://bugs.ruby-lang.org/