Issue #7897 has been updated by drbrain (Eric Hodel).


As Vit Ondruch has noted, it seems to be a bug in the Makefile generated by mkmf.rb as ruby 1.9.3 without Murata-san's patch correctly installs lib/msgpack.bundle.

Nobu, can you check it?

Just to be safe, I committed Murata-san's patch and will open a backport request.
----------------------------------------
Bug #7897: rubygems 2.0 has an incompatibility about installation of extension libraries if gem package does not contain lib directory
https://bugs.ruby-lang.org/issues/7897#change-36720

Author: mrkn (Kenta Murata)
Status: Closed
Priority: Urgent
Assignee: drbrain (Eric Hodel)
Category: lib
Target version: 2.0.0
ruby -v: ruby 2.0.0dev (2013-02-08 trunk 39161) [x86_64-darwin11.4.2]


Hi,

rubygems 2.0 has an incompatibility about installation of extension libraries.

If a gem package does not contain lib directory,
an extension library file is copied as a file named "lib".

You can reproduce this problem by installing msgpack version 0.4.7.



-- 
http://bugs.ruby-lang.org/