Issue #6744 has been updated by mame (Yusuke Endoh).

Target version changed from 2.0.0 to next minor

Looks a feature request rather than a bug?
Anyway I postpone this ticket to next minor.

-- 
Yusuke Endoh <mame / tsg.ne.jp>
----------------------------------------
Bug #6744: ruby unable to run system commands that require elevated privileges
https://bugs.ruby-lang.org/issues/6744#change-36526

Author: rogerdpack (Roger Pack)
Status: Assigned
Priority: Normal
Assignee: usa (Usaku NAKAMURA)
Category: 
Target version: next minor
ruby -v: ruby 1.9.3p194 (2012-04-20) [i386-mingw32]


Examples, download this file:
http://sourceforge.net/projects/smplayer/files/SMPlayer/0.6.9/smplayer-0.6.9-win32.exe

then attempt
>> system("./smplayer-0.6.9-win32.exe")
=> nil

(it should have worked, but displayed an elevated privilege command prompt--python does this, cmd does this).
Cheers!
-roger-


-- 
http://bugs.ruby-lang.org/