Issue #7807 has been updated by vo.x (Vit Ondruch).

Status changed from Rejected to Open
Assignee set to nobu (Nobuyoshi Nakada)

Could you please explain? Why r39171 instead of applying my patch? Why there should be version in the path? Actually it is not Ruby version but Ruby ABI version, so it will not help you to install Ruby 1.9.1, 1.9.2 and 1.9.3 side by side, since all of them have the same ABI. In Fedora, we are pretty happy without the version for one year already.
----------------------------------------
Bug #7807: [PATCH] Remove duplicated load paths when empty version string is configured
https://bugs.ruby-lang.org/issues/7807#change-36137

Author: vo.x (Vit Ondruch)
Status: Open
Priority: Normal
Assignee: nobu (Nobuyoshi Nakada)
Category: 
Target version: 
ruby -v: ruby 2.0.0dev (2013-02-08 trunk 39161) [x86_64-linux]


=begin
My configuration options:
 ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu --program-prefix= --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/var/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-ruby-version='' --with-rubyhdrdir=/usr/include --with-ruby-pc=ruby.pc --disable-rpath --enable-shared

Prior:

 $ ruby -e "puts $:"
 /usr/lib64/ruby/site_ruby/
 /usr/lib64/ruby/site_ruby//x86_64-linux
 /usr/lib64/ruby/site_ruby
 /usr/lib64/ruby/vendor_ruby/
 /usr/lib64/ruby/vendor_ruby//x86_64-linux
 /usr/lib64/ruby/vendor_ruby
 /usr/lib64/ruby/
 /usr/lib64/ruby//x86_64-linux

After:

 $ ruby -e "puts $:"
 /usr/lib64/ruby/site_ruby
 /usr/lib64/ruby/site_ruby/x86_64-linux
 /usr/lib64/ruby/vendor_ruby
 /usr/lib64/ruby/vendor_ruby/x86_64-linux
 /usr/lib64/ruby
 /usr/lib64/ruby/x86_64-linux
  
BTW the duplicated paths caused ActiveSupport test suite errors as far as I remember [1]. Not sure if it was already changed there.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=718695
=end
 


-- 
http://bugs.ruby-lang.org/