Issue #7818 has been updated by agileanimal (Mark Madsen).


I was seeing it fail when it tries to validate without a cacert.pem for openssl - but in this case shouldn't it fall back to the pem that comes with ruby gems?
----------------------------------------
Bug #7818: Ruby 2.0.0-rc2 is not compatible with openssl 1.0.1d.
https://bugs.ruby-lang.org/issues/7818#change-36098

Author: agileanimal (Mark Madsen)
Status: Assigned
Priority: Normal
Assignee: MartinBosslet (Martin Bosslet)
Category: ext
Target version: 2.0.0
ruby -v: ruby 2.0.0dev (2013-02-08 trunk 39161) [x86_64-darwin12.3.0]


=begin
Ruby 2.0.0-rc2 is not compatible with openssl 1.0.1d.

It works as expected on 1.0.1c

When used with 1.0.1d ruby is unable to validate certificates and other things might be broken as well.

For example:  

    gem install bundler --source https://rubygems.org

will fail when linked to 1.0.1d with:

    ERROR:  While executing gem ... (OpenSSL::SSL::SSLError)
        SSL_read: bad decompression

As noted, openssl 1.0.1c works as expected.
=end


-- 
http://bugs.ruby-lang.org/