Issue #7711 has been updated by drbrain (Eric Hodel).

Status changed from Open to Assigned
Assignee set to drbrain (Eric Hodel)
Priority changed from Normal to Low
Target version changed from next minor to Next Major

I don't have any plans to remove autoload at this time.
----------------------------------------
Feature #7711: RubyGems uses autoload
https://bugs.ruby-lang.org/issues/7711#change-35466

Author: trans (Thomas Sawyer)
Status: Assigned
Priority: Low
Assignee: drbrain (Eric Hodel)
Category: lib
Target version: Next Major


Using a custom require method, I ran into an issue with RubyGems b/c it is using autoload:

  https://github.com/rubygems/rubygems/blob/master/lib/rubygems.rb#L1062-L1074

Seeing that autoload is now discouraged from standard libs (http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-core/41149), when might we see it removed?




-- 
http://bugs.ruby-lang.org/