So, no one over at ruby-talk seems to be able to tell me why my
reimplementation of autoload doesn't quite work. Can anyone here perhaps
shed some light?

  https://github.com/rubyworks/autoload/blob/master/lib/autoload.rb


https://groups.google.com/forum/?fromgroups=#!topic/ruby-talk-google/RbYIfsIV--U

Currently the error I get when running `bundle exec` is:

  bundler-1.2.3/lib/bundler/dsl.rb:128:in `initialize':
      wrong number of arguments(1 for 0) (ArgumentError)