Issue #7629 has been updated by gingerlime (Yoav Aner).


we're also seeing a very similar segmentation fault with after upgrading to 1.9.3p362 with unicorn (rails 3.2.9, postgresql 9.2)

...
vendor/bundle/ruby/1.9.1/gems/activerecord-3.2.9/lib/active_record/relation.rb:241: [BUG] Segmentation fault
ruby 1.9.3p362 (2012-12-25 revision 38607) [x86_64-linux]
----------------------------------------
Bug #7629: Segmentation fault
https://bugs.ruby-lang.org/issues/7629#change-35122

Author: atd (Antonio Tapiador)
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 
ruby -v: ruby 1.9.3p362 (2012-12-25 revision 38607) [i686-linux]


ruby 1.9.3p362 produces a segmentation fault in our tests in Travis.

You can find a full trace of the bug at https://travis-ci.org/ging/social_stream/jobs/3843546


-- 
http://bugs.ruby-lang.org/