Thank you and sorry for my late response.

I will change method names as your proposal with the following patch.
http://www.atdot.net/sp/view/fwdffm/readonly

(2012/12/04 15:43), KOSAKI Motohiro wrote:
>>   handle_interrupt(X => :immediately)
>>   handle_interrupt(Y => :on_blocking)
>>   handle_interrupt(Z => :never)
>>
>> Handle interrupt X immediately.  Handle interrupt Y on_blocking.
>> Handle interrupt Z never.  You could also write:
>>
>>   asynchronous_event(X => :immediate)
>>   asynchronous_event(Y => :on_blocking)
>>   asynchronous_event(Z => :defer)
>>
>> Or, (but this is getting a bit too long):
>>
>>   handle_asynchronous_event(X => :immediately)
>>   handle_asynchronous_event(Y => :on_blocking)
>>   handle_asynchronous_event(Z => :never)
> 
> I'm ok both handle_interrupt and handle_asynchronous_event.
> (and I also agree  :defer should go back :never if we accept this name)
> 
> 
> 
>> My vote is for handle_interrupt or asynchronous_event, but all these
>> read as idiomatically correct English jargon.  I adjusted the values in
>> the hashes slightly when using a verb phase for the method name to make
>> the resulting syntax more consistent with English grammar.
>>
>> The
>>   Thread#pending_interrupt?
>>
>> method name you propose is also perfectly good English.
>> Either name is much more descriptive than Thread#async_interrupt?
> 
> I'm ok this one too.
> 


-- 
// SASADA Koichi at atdot dot net