Issue #7581 has been reported by vo.x (Vit Ondruch).

----------------------------------------
Bug #7581: DTrace test should be executed against RUNRUBY
https://bugs.ruby-lang.org/issues/7581

Author: vo.x (Vit Ondruch)
Status: Open
Priority: Normal
Assignee: tenderlovemaking (Aaron Patterson)
Category: 
Target version: 
ruby -v: ruby 2.0.0dev (2012-12-17 trunk 38422) [x86_64-linux]


Currently, the DTrace tests are executed using system Ruby [1], which is apparently wrong, since system Ruby might be of different version or may not be available. The tests should be executed against RUNRUBY, which were just build.

[1] https://github.com/ruby/ruby/blob/trunk/test/dtrace/helper.rb#L29


-- 
http://bugs.ruby-lang.org/