Issue #3784 has been updated by mame (Yusuke Endoh).

Target version changed from 1.9.3 to 2.0.0

Nahi-san, can you reproduce this issue?

-- 
Yusuke Endoh <mame / tsg.ne.jp>
----------------------------------------
Bug #3784: Seg fault in IO.select from webrick
https://bugs.ruby-lang.org/issues/3784#change-34567

Author: enrico (Enrico Brunetta)
Status: Feedback
Priority: Normal
Assignee: nahi (Hiroshi Nakamura)
Category: lib
Target version: 2.0.0
ruby -v: ruby 1.9.2p0 (2010-08-18 revision 29036) [x86_64-darwin10.4.0]


=begin
 I get this intermittently (approximately once a day) on my OSX 10.6.4. I have used rvm to install 1.9.2-p0 
 
 /usr/local/Cellar/ruby/1.9.2-p0/lib/ruby/1.9.1/webrick/server.rb:90: [BUG] Segmentation fault
 ruby 1.9.2p0 (2010-08-18 revision 29036) [x86_64-darwin10.4.0]
 
 -- control frame ----------
 c:0012 p:---- s:0055 b:0055 l:000054 d:000054 CFUNC  :select
 c:0011 p:0106 s:0048 b:0048 l:000038 d:000047 BLOCK  /usr/local/Cellar/ruby/1.9.2-p0/lib/ruby/1.9.1/webrick/server.rb:90
 c:0010 p:0007 s:0042 b:0042 l:000041 d:000041 METHOD /usr/local/Cellar/ruby/1.9.2-p0/lib/ruby/1.9.1/webrick/server.rb:22
 c:0009 p:0063 s:0039 b:0039 l:000038 d:000038 METHOD /usr/local/Cellar/ruby/1.9.2-p0/lib/ruby/1.9.1/webrick/server.rb:81
 c:0008 p:0126 s:0034 b:0034 l:001f90 d:001f90 METHOD /usr/local/Cellar/ruby/1.9.2-p0/lib/ruby/gems/1.9.1/gems/rack-1.1.0/lib/rack/handler/webrick.rb:14
 c:0007 p:0806 s:0028 b:0028 l:0001b0 d:0001b0 TOP    /usr/local/Cellar/ruby/1.9.2-p0/lib/ruby/gems/1.9.1/gems/rails-2.3.8/lib/commands/server.rb:111
 c:0006 p:---- s:0017 b:0017 l:000016 d:000016 FINISH
 c:0005 p:---- s:0015 b:0015 l:000014 d:000014 CFUNC  :require
 c:0004 p:0013 s:0011 b:0011 l:000010 d:000010 METHOD <internal:lib/rubygems/custom_require>:29
 c:0003 p:0038 s:0006 b:0006 l:0015f8 d:000128 EVAL   ./script/server:3
 c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
 c:0001 p:0000 s:0002 b:0002 l:0015f8 d:0015f8 TOP   
 ---------------------------
 -- Ruby level backtrace information ----------------------------------------
 ./script/server:3:in `<main>'
 <internal:lib/rubygems/custom_require>:29:in `require'
 <internal:lib/rubygems/custom_require>:29:in `require'
 /usr/local/Cellar/ruby/1.9.2-p0/lib/ruby/gems/1.9.1/gems/rails-2.3.8/lib/commands/server.rb:111:in `<top (required)>'
 /usr/local/Cellar/ruby/1.9.2-p0/lib/ruby/gems/1.9.1/gems/rack-1.1.0/lib/rack/handler/webrick.rb:14:in `run'
 /usr/local/Cellar/ruby/1.9.2-p0/lib/ruby/1.9.1/webrick/server.rb:81:in `start'
 /usr/local/Cellar/ruby/1.9.2-p0/lib/ruby/1.9.1/webrick/server.rb:22:in `start'
 /usr/local/Cellar/ruby/1.9.2-p0/lib/ruby/1.9.1/webrick/server.rb:90:in `block in start'
 /usr/local/Cellar/ruby/1.9.2-p0/lib/ruby/1.9.1/webrick/server.rb:90:in `select'
 
 -- C level backtrace information -------------------------------------------
 
 [NOTE]
 You may have encountered a bug in the Ruby interpreter or extension libraries.
 Bug reports are welcome.
 For details: http://www.ruby-lang.org/bugreport.html
 
 Abort trap
=end



-- 
http://bugs.ruby-lang.org/