Issue #7427 has been updated by jonforums (Jon Forums).


I can build 2.0.0-preview1 on 32bit XP SP3 (right click My Computer -> properties) using the mingw-32-4.6.2 toolchain. `make test` has 0 errors, `make test-all` has 7 failures, 3 errors, 86 skips.

Unfortunately, our mingw64-32-4.7.2 toolchain blows up because the first conftest.c fails with an internal compiler error and an unhelpful log msg. And it seems `rake devkit:sh` behaves differently on XP and Win7. FYI for your scenario, but the gcc 4.7.2 issue is critical for us (rubyinstaller) to repro, find and fix.

Use the following instead of my previous versions. Remember to run a `rake clean` to clean out the build sandbox (devkit, ruby, libs, tools) unless you're in a C-tweak -> rebuild cycle and don't want to rebuild everything.

  rake ruby19 local=c:\projects\ruby dkver=mingw-32-4.6.2
  rake devkit:sh dkver=mingw-32-4.6.2

I'm out for the evening. If this doesn't get you moving again, hopefully one of the others will saunter in with a solution.

Hey, I'm impressed. A VB vm on your Mac running XP and checking out the two-step that can be mingw. What's this world coming to ;)
----------------------------------------
Feature #7427: Update Rubygems
https://bugs.ruby-lang.org/issues/7427#change-34261

Author: mame (Yusuke Endoh)
Status: Closed
Priority: Urgent
Assignee: drbrain (Eric Hodel)
Category: 
Target version: 2.0.0


Eric Hodel is planning to update Rubygems by the end of November.
See [ruby-core:48212].

Eric, what's the status?

-- 
Yusuke Endoh <mame / tsg.ne.jp>


-- 
http://bugs.ruby-lang.org/