Issue #7427 has been updated by jonforums (Jon Forums).


drbrain (Eric Hodel) wrote:
> set and ruby -v: http://paste.segment7.net/ace.html

Looks ok.

 
> gem env: http://paste.segment.net/acf.html

Bad link..should be http://paste.segment7.net/acf.html (missing 7). This in GEM_PATHS is troubling but may be a red-herring since PATH doesn't appear to have other mingw installs:

  C:/MinGW/msys/1.0/home/drbrain/.gem/ruby/1.9.1

Try the following on this snippet http://pastie.org/5460872 copied to c:\projects\rubyinstaller as gcc_atomic.c

  cd c:\projects\rubyinstaller
  rake devkit dkver=mingw64-32-4.7.2
  rake devit:sh
  gcc --version   # should be `gcc.exe (rubenvb-4.7.2-release) 4.7.2`
  gcc -Wall -o atomics.exe gcc_atomic.c
  atomics.exe     # should be `Got 1`

If you try the same but with `rake devkit dkver=mingw-32-4.6.2` you're rewarded with:

  C:\Users\Jon\AppData\Local\Temp\ccgG9KBw.o:gcc_atomic.c:(.text+0x2e): undefined reference to `__sync_val_compare_and_swap_4'
  collect2: ld returned 1 exit status

Don't know what this means just yet since I can build with both `mingw64-32-4.7.2` and `mingw-32-4.6.` Back in awhile after I play on XP.

When you run the following, do you get something similar?  Specifically the front part of PATH.

C:\projects\rubyinstaller-git>rake devkit dkver=mingw64-32-4.7.2
mkdir -p C:/projects/rubyinstaller-git/sandbox/.checkpoints
touch C:/projects/rubyinstaller-git/sandbox/.checkpoints/.msys-download
...SNIP...
touch C:/projects/rubyinstaller-git/sandbox/.checkpoints/.mingw-extract
rm -r sandbox/devkit/mingw/mingw32
touch C:/projects/rubyinstaller-git/sandbox/.checkpoints/.mingw-prepare

C:\projects\rubyinstaller-git>rake devkit:sh
Temporarily enhancing PATH to include DevKit...
sh-3.1$ echo $PATH
/usr/bin:/usr/mingw/bin:/c/Program Files/CollabNet/Subversion Client:/c/Windows/system32:/c/Windows:/c/Windows/System32/Wbem:
/c/Windows/System32/WindowsPowerShell/v1.0/:/c/Program Files/ATI Technologies/ATI.ACE/Core-Static:
/c/Program Files/Microsoft Windows Performance Toolkit/:/c/Windows/System32/WindowsPowerShell/v1.0/:/c/tools:
/c/Python27/Scripts:/c/Python27:/c/ruby193/bin:/c/scala/bin:/c/lua/bin:/c/groovy/bin:/c/gnuwin32/curl/bin:/c/gnuwin32/diff/bin:
/c/gnuwin32/grep/bin:/c/gnuwin32/findutils/bin:/c/gnuwin32/sed/bin:/c/gnuwin32/gawk/bin:/c/gnuwin32/less/bin:/c/gnuwin32/upx/bin:
/c/gnuwin32/coreutils/bin:/c/Apps/android-sdk/tools:/c/Apps/android-sdk/platform-tools:/c/Apps/Wix:/c/Apps/git/cmd:/c/Apps/Chocolatey/bin:.

sh-3.1$ gcc --version
gcc.exe (rubenvb-4.7.2-release) 4.7.2
Copyright (C) 2012 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
----------------------------------------
Feature #7427: Update Rubygems
https://bugs.ruby-lang.org/issues/7427#change-34260

Author: mame (Yusuke Endoh)
Status: Closed
Priority: Urgent
Assignee: drbrain (Eric Hodel)
Category: 
Target version: 2.0.0


Eric Hodel is planning to update Rubygems by the end of November.
See [ruby-core:48212].

Eric, what's the status?

-- 
Yusuke Endoh <mame / tsg.ne.jp>


-- 
http://bugs.ruby-lang.org/