Issue #7427 has been updated by luislavena (Luis Lavena).


drbrain (Eric Hodel) wrote:
> The RubyInstaller build tools are fantastic!
> 
> Unfortunately I fail at exactly the same spot, undefined reference to __sync_val_compare_and_swap_4.
> 
> Looking closer, ruby_atomic.h checks HAVE_GCC_ATOMIC_BUILTINS and assumes the one I need is there even though it is missing.
> 

That is weird, mingw-w64 provides that, which is the compiler we have been using for Ruby 2.0 (GCC 4.7.2)

Perhaps your other mingw-inst-get installation got in the way?

> There is a check in configure for linux for this builtin, but not for mingw32.
> 
> Removing HAVE_GCC_ATOMIC_BUILTINS from config.h allows linking of miniruby

I'll take a look later tonight. I also have a drop and use package that contains the compilers, a base Ruby and everything to get you up and running quickly.

----------------------------------------
Feature #7427: Update Rubygems
https://bugs.ruby-lang.org/issues/7427#change-34248

Author: mame (Yusuke Endoh)
Status: Closed
Priority: Urgent
Assignee: drbrain (Eric Hodel)
Category: 
Target version: 2.0.0


Eric Hodel is planning to update Rubygems by the end of November.
See [ruby-core:48212].

Eric, what's the status?

-- 
Yusuke Endoh <mame / tsg.ne.jp>


-- 
http://bugs.ruby-lang.org/