(2012/11/26 13:53), kosaki (Motohiro KOSAKI) wrote:
> Ko1 suggested me defer_async_interrupt or async_interrupt_timing(...){...}.
> Both looks acceptable to me.
> 
> async_interrupt_timing(X => :immediate) 
> async_interrupt_timing(X => :on_blocking) 
> async_interrupt_timing(X => :defer)    # instead of :never
> 
> The rest problem is async_interrupt_timing(X => :on_blocking) looks still strange.
> because of, bignum don't have blocking point for example.

I rename it.

> Now, two idea was raised.
> 
> 23:14 ko1_ndk: async_interrupt_timing(Y => :checkpoint)
> 23:15 ko1_ndk: async_interrupt_timing(Y => :cancelpoint)
> 
> To me, this is not unacceptable. but not fine too. ;-)
> Any good name idea is highly welcome.

Highly welcome.

-- 
// SASADA Koichi at atdot dot net