Issue #7375 has been updated by tenderlovemaking (Aaron Patterson).

Status changed from Assigned to Closed
% Done changed from 0 to 100

I fixed this in r37919, but it didn't seem to close.  I'm closing now.
----------------------------------------
Feature #7375: embedding libyaml in psych for Ruby 2.0
https://bugs.ruby-lang.org/issues/7375#change-34090

Author: tenderlovemaking (Aaron Patterson)
Status: Closed
Priority: High
Assignee: tenderlovemaking (Aaron Patterson)
Category: 
Target version: 2.0.0


People have a hard time using psych (and thus rubygems) because it depends on libyaml. We can ease upgrades by embedding libyaml in order to eliminate the library dependency.

libyaml is MIT license, so it shouldn't impact Ruby's license.

Matz, may I embed libyaml for preview2?


-- 
http://bugs.ruby-lang.org/