Issue #4233 has been updated by mame (Yusuke Endoh).

Assignee changed from nahi (Hiroshi Nakamura) to drbrain (Eric Hodel)

Is this really a feature request?  Looks a (low-priority?) bug to me.
drbrain, what do you think about this?

-- 
Yusuke Endoh <mame / tsg.ne.jp>
----------------------------------------
Feature #4233: autoload Can't Require Gems
https://bugs.ruby-lang.org/issues/4233#change-33318

Author: runpaint (Run Paint Run Run)
Status: Assigned
Priority: Normal
Assignee: drbrain (Eric Hodel)
Category: core
Target version: 2.0.0


=begin
 Is it intentional that when used via `autoload`, `require` can't handle Gem names?
 
     run@desktop:~/mir/ruby$  ???  ruby -e 'p require "nokogiri"'
     true
     run@desktop:~/mir/ruby$  ???  ruby -e 'autoload(:N, "nokogiri"); p N'
     -e:1:in `<main>': cannot load such file -- nokogiri (LoadError)
=end



-- 
http://bugs.ruby-lang.org/