Issue #7384 has been reported by trans (Thomas Sawyer).

----------------------------------------
Feature #7384: Rename #each_with_object to #each_with
https://bugs.ruby-lang.org/issues/7384

Author: trans (Thomas Sawyer)
Status: Open
Priority: Normal
Assignee: 
Category: core
Target version: next minor


I propose that #each_with_object be renamed to #each_with, for the following reasons:

1. The original name is too long. When general purpose methods have long names it tends to deter developers from using them even when they are a good fit to the use case.

2. The last word, "object", is completely redundant. All methods that take an argument could say the same thing. e.g. Array#push is not named #push_object though that is obviously what it means.

3. The change need not effect backward compatibility b/c #each_with_object can remain an alias of #each_with for as long as deemed necessary. 



-- 
http://bugs.ruby-lang.org/