Looks good.  Matz, could you accept this?

まつもとさん、2.0.0 は libyaml が事実上必須なので (ないと rubygems が動かない) 、
ビルドが面倒という FAQ が出そうです。
aaron に相談したところ、libyaml のソースコードをまるごと psych にバンドルする
パッチを作ってくれました。

libyaml は MIT ライセンスなのでライセンス上の問題はないと思います。
承認して頂けますか?

-- 
Yusuke Endoh <mame / tsg.ne.jp>


2012/11/17 tenderlovemaking (Aaron Patterson) <aaron / tenderlovemaking.com>:
>
> Issue #7375 has been reported by tenderlovemaking (Aaron Patterson).
>
> ----------------------------------------
> Feature #7375: embedding libyaml in psych for Ruby 2.0
> https://bugs.ruby-lang.org/issues/7375
>
> Author: tenderlovemaking (Aaron Patterson)
> Status: Open
> Priority: Normal
> Assignee:
> Category:
> Target version:
>
>
> People have a hard time using psych (and thus rubygems) because it depends on libyaml. We can ease upgrades by embedding libyaml in order to eliminate the library dependency.
>
> libyaml is MIT license, so it shouldn't impact Ruby's license.
>
> Matz, may I embed libyaml for preview2?
>
>
> --
> http://bugs.ruby-lang.org/
>



-- 
Yusuke Endoh <mame / tsg.ne.jp>