On Nov 16, 2012, at 11:27 AM, "Shota Fukumori (sora_h)" =
<sorah / tubusu.net> wrote:
> On Sat, Nov 17, 2012 at 12:54 AM, Ramkumar Ramachandra
> <artagnon / gmail.com> wrote:
>> Ah, thanks; works now.  However, I'm able to build and install `ruby`
>> without `libyaml-dev`, and the resulting `gem` executable is broken.
>> Isn't that a bug?
>>=20
>> Ram
>=20
> rubygems' test fails because it expects "psych" (libyaml binding) =
exists,
> but gem command seems not broken (It outputs message like "please
> install libyaml and build ruby again").
>=20
> @drbrain what do you think about psych LoadError in gem's test?

It's impossible to install gems without a YAML interpreter, so I think =
the LoadError is OK.

Aaron is trying to embed libyaml in psych, so maybe that will fix these =
errors.=