Hi,

First off: +1 on your request about the Pathname(). Although I don't see 
the the real problem with it being named after a class. However, I don't 
think it's necessary to have a shortcut which is four characters shorter 
than the thing it shortens (afaict it is a shorthand of Pathname.new - 
does it really hurt to write those four characters?). Also, another 
problem I see with it is that it doesn't conform with the usual method 
naming scheme.

Secondly, I regard Pathname as a collection - in the exact same way I 
regard Dir as a collection; a collection of path names that is. And I 
think others do too. So I don't see why we shouldn't have said method. 
It could even alias to ::glob as Dir[] does; that would give some 
consistency (though I wouldn't mind if we'd continue not to have ::[]).

P.S.: If I replied wrong in any way, please let me know, as I couldn't 
find a guide on how to reply to issues (if it's any different than 
replying like in a "regular" mailing list). Thanks!