Issue #7340 has been updated by merborne (kyo endo).


matz (Yukihiro Matsumoto) wrote:
> I dislike #into because it may or may not put something into the argument.
> I am OK with #each_with.
> 
> Matz.

I would appreciate if you could look at #6687. but #each_with is OK for me :-)
----------------------------------------
Feature #7340: 'each_with' or 'into' alias for 'each_with_object'
https://bugs.ruby-lang.org/issues/7340#change-32835

Author: nathan.f77 (Nathan Broadbent)
Status: Open
Priority: Low
Assignee: 
Category: lib
Target version: next minor


Following on from the discussions at #7297 and #7241, it is apparent that a shorter alias for 'each_with_object' would be much appreciated.


-- 
http://bugs.ruby-lang.org/