Issue #7340 has been updated by matz (Yukihiro Matsumoto).


I dislike #into because it may or may not put something into the argument.
I am OK with #each_with.

Matz.

----------------------------------------
Feature #7340: 'each_with' or 'into' alias for 'each_with_object'
https://bugs.ruby-lang.org/issues/7340#change-32832

Author: nathan.f77 (Nathan Broadbent)
Status: Open
Priority: Low
Assignee: 
Category: lib
Target version: next minor


Following on from the discussions at #7297 and #7241, it is apparent that a shorter alias for 'each_with_object' would be much appreciated.


-- 
http://bugs.ruby-lang.org/