Issue #6421 has been updated by luislavena (Luis Lavena).

Target version changed from 1.9.3 to 2.0.0

usa (Usaku NAKAMURA) wrote:
> Sorry, I can't understand the conclusion.
> 
> Please commit the patch or reject this ticket.

Sorry for late response. I've committed this to trunk in r37527

Will open a backport request too.

Thank you
----------------------------------------
Feature #6421: Add zlibwapi to extconf.rb file for zlib library
https://bugs.ruby-lang.org/issues/6421#change-32512

Author: djberg96 (Daniel Berger)
Status: Closed
Priority: Normal
Assignee: luislavena (Luis Lavena)
Category: ext
Target version: 2.0.0


The vstudio contrib solution in zlib 1.2.7 creates a "zlibwapi" dll file. According to the readme.txt file, "The new DLL was renamed because there exist several incompatible versions of zlib.dll on the Internet."

So, I propose this very modest adjustment to the extconf.rb file for zlib:

-if %w'z libz zlib1 zlib zdll'.find {|z| have_library(z, 'deflateReset')} and
+if %w'z libz zlib1 zlib zdll zlibwapi'.find {|z| have_library(z, 'deflateReset')} and

Regards,

Dan


-- 
http://bugs.ruby-lang.org/