Issue #7259 has been reported by denofevil (Dennis Ushakov).

----------------------------------------
Bug #7259: ruby-debug-base19x does not compile on 2.0.0-head
https://bugs.ruby-lang.org/issues/7259

Author: denofevil (Dennis Ushakov)
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 2.0.0
ruby -v: ruby 2.0.0dev (2012-10-12) [x86_64-darwin12.2.0]


I'm trying to make ruby-debug-base19x used by IDE debugger work on 2.0.0-head. I've managed to get it mostly compiling (latest sources are at https://github.com/ruby-debug/ruby-debug-base19) and found one major problem: rb_vm_get_sourceline is no longer exported which results in following:

(({dyld: lazy symbol binding failed: Symbol not found: _rb_vm_get_sourceline
Referenced from: /Users/denofevil/Code/ruby-debugger/ruby-debug-base19/ext/ruby_debug/ruby_debug.bundle
Expected in: flat namespace

dyld: Symbol not found: _rb_vm_get_sourceline
Referenced from: /Users/denofevil/Code/ruby-debugger/ruby-debug-base19/ext/ruby_debug/ruby_debug.bundle
Expected in: flat namespace}))

I remember that RUBY_FUNC_EXPORTED was added as a workaround for 1.9.3 (http://bugs.ruby-lang.org/issues/5193), but it's no longer present on head.
Is there some new API we should be using?


-- 
http://bugs.ruby-lang.org/