On Tue, Oct 30, 2012 at 07:58:33PM +0900, rosenfeld (Rodrigo Rosenfeld Rosas) wrote:
> 
> Issue #7241 has been updated by rosenfeld (Rodrigo Rosenfeld Rosas).
> 
> 
> Maybe .hash_map? each_with_object is a too long name for a very common needed method. Many have asked for a method like it (including me) because they couldn't find "each_with_object" and they ended up learning here after asking for such a method.
> 
> Maybe "hash_map" could be a better name for this.

`each_with_object` isn't specific to hashes, and isn't doing list
translation like `map` does.

IOW, it sounds perfect for ActiveSupport. ;-)

-- 
Aaron Patterson
http://tenderlovemaking.com/