Issue #7155 has been updated by t0d0r (Todor Dragnev).


Sorry, syntax error in title "open-air" =>is URI lib from core library  ./src/ruby-1.9.3-p286/lib/uri/common.rb
----------------------------------------
Bug #7155: Invalid byte sequence in US-ASCII when using open-air
https://bugs.ruby-lang.org/issues/7155#change-30585

Author: t0d0r (Todor Dragnev)
Status: Open
Priority: Normal
Assignee: 
Category: lib
Target version: 
ruby -v: 1.9.3p286


Invalid byte sequence in US-ASCII on ruby 1.9.3

I receive that error when trying to open url with bulgarian text (utf-8: "??????????"). It seems that the problem is in uri/common.rb from ruby standard library...

adding str.force_encoding(Encoding::BINARY) to following method fix the problem

class URI::Parser
  def escape(str, unsafe = @regexp[:UNSAFE])
    unless unsafe.kind_of?(Regexp)
      # perhaps unsafe is String object
      unsafe = Regexp.new("[#{Regexp.quote(unsafe)}]", false)
    end
    str.force_encoding(Encoding::BINARY) # FIX
    str.gsub(unsafe) do
      us = $&
        tmp = ''
      us.each_byte do |uc|
        tmp << sprintf('%%%02X', uc)
      end
      tmp
    end.force_encoding(Encoding::US_ASCII)
  end
end

One more suggestion -  maybe US_ASCII must be replaced to Encoding::BINARY too?


-- 
http://bugs.ruby-lang.org/