On Sep 20, 2012, at 6:14 PM, SASADA Koichi <ko1 / atdot.net> wrote:
> Revisit.
> 
> I made a patch:
> https://github.com/ko1/ruby/tree/all_refs
> 
>  ObjectSpace.all_references_from(obj) #=> [...]
> 
> I don't any strong idea about naming.
> 
>  - ObjectSpace.contains(obj)
>  - ObjectSpace.reachable_set(obj)
>  - ObjectSpace.transitive_closure(obj)
> 
> "ObjectSpace.reachable_objects_from(obj)" is more descriptive?

I think this name is the most descriptive.