On Wed, Sep 19, 2012 at 9:38 PM, Charles Oliver Nutter
<headius / headius.com> wrote:
> I think it has been discussed before, but autoload really should
> redispatch to require. As it stands today, I don't think it picks up
> e.g. RubyGems require hooks either, even though RubyGems is a
> standard, built-in feature now.

I've brought it up before and the conclusion was that autoload is
deprecated (b/c of threading issues I believe), although it won't
actually be removed from the language until 3.0. Which seems a rather
weak conclusion when you consider that 3.0 probably won't be ready for
another five years or more. So I'd still like to see a fix to this
issue in the mean time --otherwise remove autoload from the language
sooner.